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Solutions to Known Issues


Solutions to Known Issues


Can Not Copy Google Docs/Sheets from Google Drive to My Computer

I am trying to copy gsheet and gdoc files from Google Drive to my computer using ViceVersa, but I get the error "Invalid Function". Why?

Google Drive file formats are cloud-only files. gdoc and gsheets are shortcuts to the document / sheet and can't be copied locally. If you want a traditional file that you can copy, open and edit locally, you need to use a non-native file format such as .docx .xlsx .pptx etc. You must first download or convert your files to the .docx or .xlsx format before you can copy them to your computer.


Errors while running a large number of profiles concurrently in VVEngine

SYMPTOMS

When running a large number of profiles concurrently in VVEngine, the following errors may appear:

  • Some of the profiles may stop with “out-of-memory” or "Windows heap depletion" errors.
  • Some of the profiles complete, however without copying any files (this may happen only in versions before 2.5 build 2503).
  • Other profiles complete properly.

CAUSE

This behaviour may occur if the Windows desktop heap (when VVEngine is running as a standard program) or the non-interactive heap (when VVEngine is running as a Windows Service)  in the WIN32 subsystem is depleted.
Windows Heap depletion can happen because other programs / services in addition to VVEngine may be using the memory allocated in the Windows Heap.

SOLUTION

a) Limit the amount of profiles that are running concurrently by scheduling them to run at different times.

or

b) Increase the Windows desktop heap size:

Important: This section contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: http://support.microsoft.com/kb/322756/

1.Run Registry Editor (Regedt32.exe).
2.From the HKEY_LOCAL_MACHINE subtree, go to the following key: \System\CurrentControlSet\Control\Session Manager\SubSystems
3.Select the Windows value.
4.From the Edit menu, choose String.
5.Increase the SharedSection parameter:
SharedSection uses the following format to specify the system and desktop heaps:
SharedSection=xxxx,yyyy,zzzz
For 32-bit operating systems, increase the yyyy value to "12288";
Increase the zzzz value to "1024".
For 64-bit operating systems, increase the yyyy value to "20480";
Increase the zzzz value to "1024".
6. Restart the computer.

Note: Microsoft also provides a tool that can do the above steps automatically. The tool can be found at http://support.microsoft.com/kb/126962 or at http://support.microsoft.com/kb/947246 for Windows Vista, 7, 2008.

References:

- "Out of Memory" error message appears when you have a large number of programs running: http://support.microsoft.com/kb/126962

- You may receive an "Out of Memory" error message because of the desktop heap limitation in Windows Vista or in Windows 7: http://support.microsoft.com/kb/947246

- Increasing the Desktop Application Heap: http://ss64.com/nt/syntax-desktopheap.html

- Desktop Heap Overview: http://blogs.msdn.com/b/ntdebugging/archive/2007/01/04/desktop-heap-overview.aspx

- Desktop Heap Overview - Part 2: http://blogs.msdn.com/b/ntdebugging/archive/2007/07/05/desktop-heap-part-2.aspx

- Sessions, Desktops and Windows Stations: http://blogs.technet.com/b/askperf/archive/2007/07/24/sessions-desktops-and-windows-stations.aspx

- Services, Desktops, and Window Stations: http://support.microsoft.com/kb/171890


Fix VVScheduler Error: "A Specified Logon Session Does not Exist"

I Get 'Exit Code 2, the system cannot find the path specified' when Running ViceVersa from VVScheduler. Why?

This error does not happen when you run ViceVersa manually by clicking on "Compare".

This can occur if you are working with a mapped network drive. Drive mappings may not be available when a scheduled task runs even if you set up the task to log in with your user name and password.

Solution:
- Set up the folders as UNC paths rather than mapped drive letters, e.g. \\server\share\, or remap the network drive in the ViceVersa PRO profile settings (profile settings -> folders -> network).


Mapped Drives Might Not Be Available or Not Found when ViceVersa Is Run with 'Elevated Privileges'

Running a program with "Elevated Privileges" is when a program is run by a user that is granted the ability to do more than just a standard user. A standard user is someone that has no administrative privileges in any capacity. By default, ViceVersa runs under standard user rights, without any administrative privileges.

However, ViceVersa can also be run with “Elevated Privileges” if running from the VVEngine, the VVScheduler or by right-clicking on the ViceVersa icon and then selecting “Run as Administrator”.

When running with Elevated Privileges, there could be an issue accessing mapped drives, if they were mapped under a standard user. This is a general Windows issue, not specific to ViceVersa. More information can be found on the Microsoft website:

Mapped drives are not available from an elevated prompt when UAC is configured to "Prompt for credentials" in Windows


Possible Solutions:


a) Map the drive again in the ViceVersa profile settings, so that the drive is remapped by ViceVersa each time the profile runs. Read More.

b) Enable the EnableLinkedConnections option in the Windows Registry:

  • Click Start, type regedit in the Start programs and files box, and then press ENTER.
  • Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
    \CurrentVersion\Policies\System.
  • Point to New, and then click DWORD Value.
  • Type EnableLinkedConnections, and then press ENTER.
  • Right-click EnableLinkedConnections, and then click Modify.
  • In the Value data box, type 1, and then click OK.
  • Exit Registry Editor, and then restart the computer.


Mapped Network Drives Do Not Work in Scheduled Tasks

Mapped network drives do not work in scheduled tasks, unless you explicitly map them before running the task (see note 1 below). Regardless, they may still fail for a number of reasons.

If you plan to schedule a ViceVersa profile to run in VVScheduler, VVLauncher or VVEngine (or on the command line), make sure you use the UNC network path directly in the ViceVersa profile, instead of the mapped drive.

For instance, instead of the mapped drive Y:\ use the UNC path \\ComputerName\Share\

If you need to provide a user / password combination to access \\ComputerName\Share\ , you can enter that information in the ViceVersa profile: profile settings -> folders -> network.

----------------
Note 1:
It is possible to re-map a network drive in ViceVersa -> profile settings -> folders -> network. This requires ViceVersa version 3 or newer.

----------------
Note 2:
If you are running VVEngine as a Windows Service, under the LocalSystem account, then the service won't have access to the network at all and using UNC paths will also fail. In this case, set the service to run under the NetworkService account or another account with access to the network. For more information on service accounts see: http://msdn.microsoft.com/en-us/library/ms686005(VS.85).aspx


Profile getting stuck on 'Comparing Done.'

When comparing very large file data sets (many terabytes), ViceVersa PRO could get stuck on 'Comparing Done'. This issue has been fixed in ViceVersa PRO 2.5 build 2517, released in May 2016 (or newer).


Slow File Deletion in Windows Vista

If you experience slow file deletion by ViceVersa when running on Windows Vista, it is most likely caused by sending files to the Recycle Bin.

The solution is to disable the option to send files to the Recycle Bin when deleting. The option is accessed from the ViceVersa main menu -> view -> preferences.


Why Outlook OST files do not copy on Windows Vista, when using VSS Volume Shadow Copies?

When using VSS Volume Shadow Copies in Vista, ViceVersa PRO gives this error message if you try to copy an Outlook OST file:

"Can not open outlook.ost. The file could not be located."

This is by design in Windows Vista. Windows Vista Volume Shadow Copies do not include Outlook OST files.
The following is Microsoft explanation of this design decision:

<< Maintaining changes to .ost files within shadow copies is expensive in terms of space and I/O activity. The performance impact doesn’t occur during the image backup itself--the only extra work at backup time is backing up the .ost file as part of the image. Instead, the performance impact occurs during the ongoing, everyday I/O to the .ost file when Outlook is running. If the .ost changes were kept in shadow copies, then every time Outlook writes to the .ost file, the result is a copy-on-write I/O hit (2 writes, 1 read). Although we have worked to reduce the impact of copy-on-writes on shadow copies,  a heavily churned file like an .ost file could still cause problems. For these reasons, and the fact that .ost files can be regenerated, we chose to delete .ost files from the shadow copy before the image is created.

Even if the performance issues didn’t exist, there are situations where Exchange will, after an .ost is restored, detect a “future” version of the .ost file and force you to delete and then regenerate the local .ost file. Therefore, it’s still preferable to regenerate an .ost file instead of restoring it. >>

Hence, OST files cannot be copied with ViceVersa PRO using VSS Volume Shadow Copies, on Windows Vista.

To prevent ViceVersa PRO from reporting this error with OST files and VSS, exclude the OST file from the profile. Add an exclude file filter to exclude the file "outlook.ost", under profile settings -> file filters.


[Error Message] 'Can not copy NTFS Additional File Streams ... The request is not supported.'

SYMPTOMS

- You are running ViceVersa PRO on a computer that is running Windows Vista or Windows Server 2008
and
- You are copying a file over the network from a computer that is NOT running Windows Vista or Windows Server 2008
and
- You get the error message: "Can not copy NTFS Additional File Streams ... The request is not supported." The message is shown for some files only.

CAUSE 

This error message is caused by a problem in Windows Vista and Windows Server 2008, as confirmed by Microsoft.

SOLUTION

- Download and install the Windows hotfix from the Microsoft website: http://support.microsoft.com/kb/973278
or
- Disable copying NTFS additional file streams in ViceVersa. The option is in the ViceVersa profile settings -> advanced settings -> details. More info re additional file streams: http://en.wikipedia.org/wiki/Fork_(filesystem)


[Error Message] 'File / Folder Path Longer Than 259 characters.'

ViceVersa PRO shows an error message when trying to copy files or folders with path longer than 259 characters. The files or folders are skipped.

You can enable support for paths longer than 259 characters in ViceVersa as shown in this article: http://www.tgrmn.com/web/kb/item31.htm 


[Error Message] The Network BIOS Command Limit Has Been Reached

VVEngine shows the error message "The network BIOS command limit has been reached" in Windows Server 2003, in Windows XP, and in Windows 2000 Server.

This error message is shown when the maximum number of simultaneous, active requests between an SMB client and the server has been reached. To increase the maximum number, follow the instructions on this Microsoft Knowledge Base article: http://support.microsoft.com/kb/810886


[VVLauncher] Installing VVLauncher as a Service, I Get the Error that VVLauncher Cannot Access a Network Drive. Why?

By default the VVLauncher service is installed under the LocalSystem account. The LocalSystem account does NOT have access to network drives. To access the network you need to run the VVLauncher service under a user account which has access to the network drive.

  • Open the Control Panel
  • Select Administrative Tools -> Services
  • Locate the service named VVLauncher
  • Double click on it or click the button "Properties"
  • Select the tab "Log In As" (this can have an other caption depending on the Windows version)
  • Enter the user account and password.
  • Click OK.
  • Restart the VVLauncher service.

Note: Do not use mapped drives to access the network. Instead use UNC paths ( eg \\server\share\ ). Services do not recognize mapped drives.


[VVLauncher] Why Do I Get a 'Cannot Monitor Folder' Error When Running VVLauncher as a Service?

You are probably running the VVLauncher service under the "Local System" account. The "Local System" account does not have access to network resources. This is causing the error. 
To solve this,
run the service under a user account which has access to the network share (you will need to specify proper user name and password).


[VVScheduler] Windows 10 Anniversary Update issues (version 1607)

The Windows 10 Anniversary Update (version 1607) was made available on 2nd August 2016 to the general public. Three problems were found in this Windows 10 update that might impact the VVScheduler:

1) Scheduled tasks in the VVScheduler may show incorrect Next Run Time, Last Run Time, Last Run Result and/or Status.

2)  If the option 'Run only if logged' is NOT set in the scheduling properties, then the scheduled task fails to run.

3) Tasks that are set to repeat every X minutes in VVScheduler may fail to run.

NOTE: All issues are now solved in the latest ViceVersa PRO 2.5 Build 2519 or newer and Windows 10 Creators Update (version 1703) or newer.


Please note that the VVEngine and VVLauncher are NOT affected by these issues. These issues only apply to VVScheduler on Windows 10 Anniversary Update (version 1607).

UPDATE:
To solve issue 1, download the latest ViceVersa PRO 2.5 Build 2519 or newer from our website:  http://www.tgrmn.com/web/download.htm
To solve issues 2 and 3, update Windows 10 to Windows 10 Creators Update (version 1703 or newer) and download and install the latest ViceVersa PRO 2.5 Build 2519 or newer.

How to Check the Windows 10 Build Version:
- Open the run command using WinKey + R
- Launch WinVer : type winver and hit OK


[VVScheduler] Windows Server 2016 issues

When the new operative system Windows Server 2016 was initially released, VVScheduler had the following issues:  

1) Scheduled tasks may have shown incorrect Next Run Time, Last Run Time, Last Run Result and/or Status.

2) If the option 'Run only if logged' was NOT set in the scheduling properties, then the scheduled tasks failed to run.

3) Tasks that were set to repeat every X minutes in VVScheduler may have failed to run.

All issues are now resolved in ViceVersa PRO 2.5 Build 2519 (or newer) download here and Windows Server 2016 with all the latest updates installed as of August 2017.

A printable version of the entire ViceVersa FAQ and Knowledge Base is also available.
For further queries, please contact us by E-Mail at support@tgrmn.com.